Fwd: dmraid on ICH10R controllers (Ubuntu bug 372170 call for testing)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Forwarded from the ubuntu-devel list.

----- Forwarded message from Robert Collins <robert.collins@xxxxxxxxxx> -----

From: Robert Collins <robert.collins@xxxxxxxxxx>
To: ubuntu-devel <ubuntu-devel@xxxxxxxxxxxxxxxx>
Cc: ataraid-list@xxxxxxxxxx
Subject: dmraid on ICH10R controllers (Ubuntu bug 372170 call for testing)
Date: Mon, 11 May 2009 18:48:12 +1000

I filed
https://bugs.edge.launchpad.net/ubuntu/+source/dmraid/+bug/372170 when I
had to replace my desktop machine - the machine smoke got out of the old
one.

I'd love it some folk could test my patch. Tests from anyone are useful,
on the unlikely chance I've really messed something up.
Particularly useful though would be some tests from people *with* ICH10R
ataraid controllers.

This will likely be desktop/workstation machines bought since
november/december last year with intel chipsets.

This particular release seems to have altered where/how the raid
metadata is stored, and my patch adds a guessed-at probe routine to the
isw format in dmraid.

How to test? - there are debs in my ppa:
https://edge.launchpad.net/~lifeless/+archive/ppa built for jaunty or
apply
http://launchpadlibrarian.net/26558415/17_fix_isw_raid_detection_1TB.patch and build yourself.
Install, run 
sudo dmraid -r -d
If you have a non-ICHxR controller, your existing ataraid setup should
be found (or non if you have none).
If you have a ICHxR but not a 10R controller, or raid disks initialized
by an earlier version of the controller, or by dmraid itself, then you
should see the first probe attempt succeed.

If you have an ICH10R controller, with disks initialized by the
controller itself, that don't work on dmraid at the moment, then
hopefully it will find them. (If you have such a controller and a spare
disk, you could also helpfully init that disk from the controller ROM to
test - I don't have disks to test with). If it doesn't find them, then
the probe logic is probably wrong - please add data to the bug, and I'll
help figure out how we can have one probe routine to find your disks and
mine.
Note that the ICH10 family of controllers have three modes - IDE, ACHI,
RAID; they must be in the RAID mode for this patch to operate (set via
the BIOS); these modes are broadly increasing functionality, with the
one caveat than an IDE->ACHI|RAID setting transition causes Windows to
bluescreen. Setting it back fixes this, but it may trigger reactivation,
so if you're dual booting some caution is in order.

I'm not subscribed to the ataraid list, so please CC me if responding
there; I am to ubuntu-devel, where this is cross-posted to, as its a
fairly core package in ubuntu and I don't want to break anything :).

-Rob

_______________________________________________
Ataraid-list mailing list
Ataraid-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/ataraid-list

[Linux RAID]     [Linux IDE]     [Linux SCSI]     [Kernel]     [Linux Books]     [Linux Admin]     [GFS]     [RPM]     [Photos]     [Yosemite Photos]     [Yosemite News]     [AMD 64]
  Powered by Linux