Re: Two isw RAID1 arrays

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hi,

> have you tried with -p in order prevent dmraid from partition activation
> and used kpartx to activate them yet to see, if that makes any diffrence
> for you ?

as previously said, "kpartx -l" worked, but "kpartx -a" gave errors.
Here they are:

device-mapper: create ioctl failed: No such device or address
device-mapper: reload ioctl failed: Invalid argument

Also, I attach the strace output for the command.

Meanwhile I booted with Knoppix 5.1 and grml 1.1 to examine the situation.
Both contain drmaid rc13 and Device-Mapper 4.10.0 (or 4.11.0). Both were able
to initialize the two RAIDs correctly with partitions. I had to activate
them one after the other, a simple "dmraid -ay" didn't work (IIRC it
activated only one RAID). But it worked. So I integrated dmraid rc13 in
my normal environment. Again, it failed to initialize the partitions.
The version of Device-Mapper there is 4.14.0 (Kernel 2.6.28.9). So it
may be a problem in the kernel. Should I file a bug, perhaps even a
regression?

My environment is a quite restricted one and contains an old glibc (2.3.2
or so). Does that matter?

Thanks,
hjb
-- 
Pro-Linux - Germany's largest volunteer Linux support site
http://www.pro-linux.de/          Public Key ID 0x3DDBDDEA

Attachment: kpartx.trace.bz2
Description: Binary data

Attachment: signature.asc
Description: Digital signature

_______________________________________________
Ataraid-list mailing list
Ataraid-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/ataraid-list

[Linux RAID]     [Linux IDE]     [Linux SCSI]     [Kernel]     [Linux Books]     [Linux Admin]     [GFS]     [RPM]     [Photos]     [Yosemite Photos]     [Yosemite News]     [AMD 64]
  Powered by Linux