R: [dm-devel] - info about dm

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Dear Luca,

many thanks for the tip...in effect I was not sure about the mailing
list I choose ;-P

(BTW: I just subscribed to such mailing list...)

Vega

-----Messaggio originale-----
Da: dm-devel-bounces@xxxxxxxxxx [mailto:dm-devel-bounces@xxxxxxxxxx] Per
conto di Luca Berra
Inviato: venerdì 9 novembre 2007 17.38
A: dm-devel@xxxxxxxxxx
Cc: ataraid-list@xxxxxxxxxx
Oggetto: Re: [dm-devel] - info about dm

Vega,
you should probably address dmraid related question to the ataraid
mailing list.
i am cc-ing the mentioned list, and doing a full quote for that reason


On Wed, Nov 07, 2007 at 02:51:52PM +0100, Vega Forneris wrote:
>Dear all,
>
>I just installed Scientific Linux 5 and I used for the first time DM
>drivers for working with the embedded RAID (the servers are IBM
xSeries,
>with an Adaptec HostRAID ASR - SATA). I really appreciate the fact that
>now Linux is able to recognize such devices, but I had some troubles
>configuring it and I?d like to have some info for better understanding
>how things work. 
>
>I?ll be a little ?verbose? for clarifying what I did and which are my
>doubts?
>
>1) Installation & Configuration
>I installed SL5 on a system which was running SL3 with HW drivers
>released by IBM. Linux was able to identify correctly the device
>(installed through CD), mapped it as /dev/mapper/asr_ and proceeded
with
>he installation.
>
>Anyway, I found a little problematic configuring it manually: I tried
to
>install SL5 on a node which was misconfigured: instead of seeing one
>device, it was managing the 2 HD (/dev/sda and /dev/sdb) as 2 separate
>devices an if I tried to configure them (at install time, via CD or
>network boot) with  DM, I got many errors about the RAID table (?ERROR:
>asr: Invalid RAID config table checksum on /dev/sda? or even ?asr:
>Invalid magic number in RAID table; saw 0x0 expected??). I tried to
>reconfigure the RAID card first via BIOS and then trying again to
>configure it via Linux (?dmsetup create ??) but even if it seemed
>working (exit code 0), then querying the device asr_ (i.e. ?dmraid ?r?)
>resulted in errors as reported above?or better, dmraid commands (-r,
>-ay, -tay,?) reported errors, while dmsetup commands  (status, ls,?)
>worked normally. The only way I found for well-configuring the device
>was to install SL3 with specific drivers, and then to install SL5 with
>DM?both commands now work perfectly
>
>In brief:
>
>If I try to configure DM-RAID from scratch and I get such errors, how
>can I do? What?s that ?RAID table?? Where is it written? Not in the MBR
>of an HD, ?cause I tried to copy the MBR of the cloned disk which had
no
>problem (still recognized as ?good? for RAID and DM) and nothing
>changed?
>
>2) Managing disks
>I configured disks in RAID 1 (mirror) but I wonder how to manage this
>RAID; in particular, how can I do for:
> - stopping a device (disk) and put it offline/and viceversa? 
> - reconfiguring/rebuilding it (due to broken/faulting HD)? 
>
>At the moment I should change a couple of disks (SMARTD warnings
>reported), but I?m scared about the ?RAID table error??
>
>Many Thanks in advance for all help you can give me?
>
>Best Regards
>Vega Forneris
>
>+--------------------------------------+
> Vega Forneris
>
> CNR ? Servizi Informatici di Campo
> Gestione servizi GRID
>
> Area di Ricerca Roma II - Tor Vergata
> Via del Fosso del Cavaliere, 100
> 00133 Roma
>
> Tel:   +39 06 4993 4667
> Fax:   +39 06 4993 4650
> Email: Vega.Forneris@xxxxxxxxxxxxx
>+--------------------------------------+
>
>
>
>--
>dm-devel mailing list
>dm-devel@xxxxxxxxxx
>https://www.redhat.com/mailman/listinfo/dm-devel

-- 
Luca Berra -- bluca@xxxxxxxxxx
        Communication Media & Services S.r.l.
 /"\
 \ /     ASCII RIBBON CAMPAIGN
  X        AGAINST HTML MAIL
 / \

--
dm-devel mailing list
dm-devel@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/dm-devel


_______________________________________________
Ataraid-list mailing list
Ataraid-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/ataraid-list

[Linux RAID]     [Linux IDE]     [Linux SCSI]     [Kernel]     [Linux Books]     [Linux Admin]     [GFS]     [RPM]     [Photos]     [Yosemite Photos]     [Yosemite News]     [AMD 64]
  Powered by Linux