isw device for volume broken after opensuse livecd boot

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hi.
I had a working raid array in an Intel ICH9R controller with the two
volumes working ( ok in windows and mandriva 2008 livecd).

I booted the Opensuse 10.3RC2 live cd and did "dmraid -ay" and got the
following errors:

ERROR: isw device for volume "RAID0" broken on /dev/sda in RAID set
"isw_bbcfceegje_RAID0"
ERROR: isw: wrong # of devices in RAID set "isw_bbcfceegje_RAID0"
[1/2] on /dev/sda
ERROR: isw device for volume "RAID1" broken on /dev/sda in RAID set
"isw_bbcfceegje_RAID1"
ERROR: isw: wrong # of devices in RAID set "isw_bbcfceegje_RAID1"
[1/2] on /dev/sda
ERROR: isw device for volume "RAID0" broken on /dev/sdb in RAID set
"isw_chgffgbhfa_RAID0"
ERROR: isw: wrong # of devices in RAID set "isw_chgffgbhfa_RAID0"
[1/2] on /dev/sdb
ERROR: isw device for volume "RAID1" broken on /dev/sdb in RAID set
"isw_chgffgbhfa_RAID1"
ERROR: isw: wrong # of devices in RAID set "isw_chgffgbhfa_RAID1"
[1/2] on /dev/sdb
ERROR: no mapping possible for RAID set isw_bbcfceegje_RAID1
ERROR: no mapping possible for RAID set isw_chgffgbhfa_RAID1

Now in the intel bios it says the disks are offline.
The livecd must have a bug that destroys all raid arrays. I think the
problem is in device-mapper, because I did "dmraid --version" and the
device-mapper was "unknown". In mandriva it is 4.11.0. Dmraid is rc14
in both.
I don't have any logs from the live boot because the network was not working.

Is there any way to recover the raid volumes? I can provide you with
all the files needed, just ask.

Thanks

Tiago Freitas

_______________________________________________
Ataraid-list mailing list
Ataraid-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/ataraid-list

[Linux RAID]     [Linux IDE]     [Linux SCSI]     [Kernel]     [Linux Books]     [Linux Admin]     [GFS]     [RPM]     [Photos]     [Yosemite Photos]     [Yosemite News]     [AMD 64]
  Powered by Linux