Re: Install grub on nvdia dmraid10 ?

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hi Tom

Yes I have, but only with kernel 2.6.14.

You need do install it by starting grub

# grub --device-map=/dev/null

Then under your grub console (where /dev/mapper/nvidia_* is your raid, in my case /dev/mapper/nvidia_hdaaghda)

grub> device (hd0,0) /dev/mapper/nvidia_*1
grub> device (hd0) /dev/mappa/nvidia_*
grub> root (hd0,0)
grub> setup (hd0)


Of course you need to change 1 to the partition your installing onto and change devices to their relevent numbers too.

Normally I would install grub onto a /boot partition rather than root.

Regards

Rob

Thomas Backlund wrote:
Hi,
has anyone successfully installed grub on a nvidia dmraid10 ?

I have a setup of 4 160GB disks configured through bios to do raid10, made the partitions under WinXP with Partition Magic and I can access the /dev/mapper/nvidia_* partitions just fine from a livecd as they are correctly identified with dmraid -ay...

But every time I try to install grub on the root partition, it bombs out claiming "no such device"

I use the same grub config as is working on a server wich runs nvidia dmraid1, (with the /dev/mapper/nvidia_* changed to point to the actual device ofcourse)

Any suggestions?

kernel is 2.6.17.11 series, dmraid is 1.0.0-0.rc11, device-mapper is 1.02.09, and grub is 0.97

--
Thomas

_______________________________________________
Ataraid-list mailing list
Ataraid-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/ataraid-list
_______________________________________________
Ataraid-list mailing list
Ataraid-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/ataraid-list

[Linux RAID]     [Linux IDE]     [Linux SCSI]     [Kernel]     [Linux Books]     [Linux Admin]     [GFS]     [RPM]     [Photos]     [Yosemite Photos]     [Yosemite News]     [AMD 64]
  Powered by Linux