Dahdi Dropping Calls

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



Hi Guys

Has anyone seen Dahdi dropping incoming calls with Hangup cause 27?
It only drops whilst we are on the phone?
Its not every single call
Any ideas?


-----Original Message-----
From: asterisk-users-bounces@xxxxxxxxxxxxxxxx [mailto:asterisk-users-bounces@xxxxxxxxxxxxxxxx] On Behalf Of Tony Mountifield
Sent: 29 June 2012 01:52 PM
To: asterisk-users@xxxxxxxxxxxxxxxx
Subject: Re:  PRI trunk between Asterisk servers does not work.

In article <4FECCD0C.1020000@xxxxxxxxxxxx>, James Sharp <james@xxxxxxxxxxxx> wrote:
> On 6/28/2012 3:53 PM, Ernie Dunbar wrote:
> > We have three Asterisk servers, Voip1, Voip2, and Voip3. Voip1 has a 
> > Wildcard TE405P (3rd Gen), Voip2 has a Wildcard TE410P/TE405P (1st 
> > Gen), and Voip3 has a Wildcard TE110P. Voip1 is the server that 
> > handles our PRI to the PSTN and we hope will allow us to failover to 
> > other Asterisk servers (ie, Voip2 and Voip3). Voip2 is our current 
> > production server, and Voip3 is being turned into our next production server.
> >
> > We're trying to build a PRI trunk between Voip1 and Voip3. Curiously 
> > enough, we've already done this between Voip1 and Voip2, so one 
> > would think that the same configuration would work between Voip1 and 
> > Voip3 as well. However, it hasn't gone so smoothly. If you're 
> > wondering why we don't just use SIP trunking between these servers, 
> > it's because faxes are not reliable over SIP trunks. I am open to suggestions however.
> >
> > At any rate, the PRI trunk between Voip1 and Voip3 isn't working, 
> > and that's my current problem.
> >
> > - I have built a T1 crossover cable, and it's plugged in between 
> > Span 3 on Voip1, and Span 1 on Voip3.
> > - I have a green light on both PRI cards for the appropriate spans.
> > - Both servers detect their cards on boot.
> > - DAHDI is installed on both servers, and all diagnostics are good, ie.
> > dahdi_test returns good results, dahdi_tool shows that the alarms 
> > are OK, and executing 'dahdi show status' on the Asterisk console 
> > shows the same.
> >
> > The chan_dahdi.conf configuration for spans 3 and 4 on Voip1 looks 
> > like
> > this:
> >
> > ; Span 3: TE4/0/4 "T4XXP (PCI) Card 0 Span 4"
> > group=3
> > context=default
> > switchtype = national
> > signalling = pri_net
> > channel => 49-71
> > group = 63
> >
> > ; Span 4: TE4/0/4 "T4XXP (PCI) Card 0 Span 4"
> > group=4
> > context=default
> > switchtype = national
> > signalling = pri_net
> > channel => 73-95
> > context = default
> > group = 63
> >
> > Span 4 goes to Voip2, which has a working PRI trunk.
> >
> > The chan_dahdi configuration for Voip3 looks like this:
> >
> > group=1
> > signalling=pri_cpe
> > switchtype=national
> > context=local
> > channel=>1-23
> > dchannel=>24
> > ;channel=25-47,49-71,73-95
> > rxgain=0
> > txgain=0
> > busydetect=yes
> > busycount=5
> >
> > resetinterval=1800
> >
> > I have a test DID, the dialplan for which on Voip1 looks like this:
> >
> > exten => 604484XXXX,1,Dial(DAHDI/g3/604482YYYY)
> >
> > But when I call 604484XXXX from my cell phone, I get no output on 
> > the Asterisk console on Voip3, and this output on Voip1:
> >
> >
> >      -- Executing [604484XXXX@local:1] Dial("DAHDI/5-1",
> > "DAHDI/g3/604482XXXX") in new stack
> > [Jun 28 12:43:32] WARNING[4219]: app_dial.c:1286 dial_exec_full: 
> > Unable to create channel of type 'DAHDI' (cause 34 - Circuit/channel congestion)
> >    == Everyone is busy/congested at this time (1:0/1/0)
> >    == Auto fallthrough, channel 'DAHDI/5-1' status is 'CONGESTION'
> >      -- Accepting call from '778839ZZZZ' to '604484XXXX' on channel 
> > 0/5, span 1
> >
> > I've also tried connecting span 3 to one of the other ports on Voip2 
> > with the same configuration, and I get the same results. I've run 
> > loopback tests on the TE110P and tested the cable thoroughly.
> >
> > Any input on this problem is greatly appreciated.
> 
> 
> You've got the spans configured as "group = 63" but you're trying to 
> dial out on group 3 (DAHDI/g3 rather than DAHDI/g63).

No, the group=63 lines are actually redundant. It is the settings *above* each channel=> line that get applied to the channels when they are created.

To the OP: what does "pri show span 3" give you on Voip1?

It might be useful to see the complete chan_dahdi.conf from Voip1.
To save space, you can list it without comments like this:

# grep -v '^;' /etc/asterisk/chan_dahdi.conf

Cheers
Tony
--
Tony Mountifield
Work: tony@xxxxxxxxxxxxx - http://www.softins.co.uk
Play: tony@xxxxxxxxxxxxxxx - http://tony.mountifield.org

--
_____________________________________________________________________
-- Bandwidth and Colocation Provided by http://www.api-digital.com -- New to Asterisk? Join us for a live introductory webinar every Thurs:
               http://www.asterisk.org/hello

asterisk-users mailing list
To UNSUBSCRIBE or update options visit:
   http://lists.digium.com/mailman/listinfo/asterisk-users



--
_____________________________________________________________________
-- Bandwidth and Colocation Provided by http://www.api-digital.com --
New to Asterisk? Join us for a live introductory webinar every Thurs:
               http://www.asterisk.org/hello

asterisk-users mailing list
To UNSUBSCRIBE or update options visit:
   http://lists.digium.com/mailman/listinfo/asterisk-users


[Gnu Gatekeeper]     [IETF Sipping]     [Info Cyrus]     [ALSA User]     [Fedora Linux Users]     [DCCP]     [Gimp]     [100% Free Online Dating]     [Yosemite News]     [Arts & Crafts]     [Yosemite Photos]     [Deep Creek Hot Springs]     [Yosemite Campsites]     [ISDN Cause Codes]


Add to Google Powered by Linux