Strange problem on ougoing call

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



Hi

i have a strange problems on my asterisk server:

I have two asterisk server.

On the first, i use realtime with a MySQL Database,
i have two user:
   USER01
   USER02
exactly the same configuration only username and password has different.


On my second server (phone is connected on this server):

I have in sip.conf:

register => USER01:1234@172.16.0.11/USER01
register => USER02:5678@172.16.0.11/USER02

[USER01]
type=friend
username=USER01
secret=1234
host=172.16.0.11
qualify=yes
dtmf=rfc2833
nat=no
canreinvite=no
canredirect=no
dtmfmode=rfc2833
disallow=all
allow=alaw
context=I-User01
musiconhold=default
insecure=port,invite

[USER02]
type=friend
username=USER02
secret=5678
host=172.16.0.11
qualify=yes
dtmf=rfc2833
nat=no
canreinvite=no
canredirect=no
dtmfmode=rfc2833
disallow=all
allow=alaw
context=I-User01
musiconhold=default
insecure=port,invite


i see the registration:

ipbx*CLI> sip show registry
Host                           dnsmgr Username       Refresh State
           Reg.Time
172.16.0.11:5060               N      USER01     105 Registered
   Tue, 24 Apr 2012 15:58:58
172.16.0.11:5060               N      USER02       105 Registered
     Tue, 24 Apr 2012 15:58:59




i have one phone connected to the context "I-User01" and another
connected to "I-User02"

When i call with the phone connected to I-User01, no problems, that's
work but when i call
with the second phone (use I-User02) i have a error:


On the first server:
[Apr 24 16:02:12] WARNING[1456]: chan_sip.c:10992 check_auth: username
mismatch, have <USER01>, digest has <USER02>
[Apr 24 16:02:12] NOTICE[1456]: chan_sip.c:18096
handle_request_invite: Failed to authenticate device "Olivier"
<sip:906280@172.16.0.70>;tag=as0cd775ab


The exten:

On I-User01: exten => _0XX.,1,Dial(SIP/USER01/${EXTEN:1},90,r)
On I-User02: exten => _0XX.,1,Dial(SIP/USER02/${EXTEN:1},90,r)



i i change on the I-User02:
     Dial(SIP/USER02/${EXTEN:1},90,r)
in
     Dial(SIP/USER01/${EXTEN:1},90,r)
all call work's.


anyone have a idea ? i think's that i have a error but don't see where

best regards
Olivier

--
_____________________________________________________________________
-- Bandwidth and Colocation Provided by http://www.api-digital.com --
New to Asterisk? Join us for a live introductory webinar every Thurs:
               http://www.asterisk.org/hello

asterisk-users mailing list
To UNSUBSCRIBE or update options visit:
   http://lists.digium.com/mailman/listinfo/asterisk-users


[Gnu Gatekeeper]     [IETF Sipping]     [Info Cyrus]     [ALSA User]     [Fedora Linux Users]     [DCCP]     [Gimp]     [100% Free Online Dating]     [Yosemite News]     [Arts & Crafts]     [Yosemite Photos]     [Deep Creek Hot Springs]     [Yosemite Campsites]     [ISDN Cause Codes]


Add to Google Powered by Linux