Kernel panic - /init: can't load library 'libgcc_s.so.1'

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



Hey everyone,

I had my Linux installation running along nicely, serving up web pages with
Boa, and was starting to feel real proud of myself (even though all of you
that helped me get things running deserve most of the credit) when my board
stopped booting properly.  I was trying to get telnetd working through
inetd, and I must've changed some configuration parameter or a file that it
didn't like.  I'm now getting a kernel panic stating that it can't load the
libgcc_s.so.1.

I reverted back to previous configurations, and it did not help, so
eventually I ran "make ARCH=arm clean" and rebuilt everything (using
buildroot).  This fixed the problem initially.  However, after screwing
around some more, the problem eventually came back.  Searching my buildroot
directory, I see that the file exists in
${PROJ_DIR}/build_arm/staging_dir/lib/ and
${PROJ_DIR}/toolchain_build_arm/gcc-4.1.2-final/gcc/ .  I've tried deleting
my project Linux directory as well as my rootfs directory, then recompiling,
but this doesn't help the situation.

I know I can do a "make clean" to fix it, but that requires a recompile of
the entire toolchain in addition to everything else, which takes an hour or
more.  Does anyone have an idea as to (a) what is causing this problem, and
(b) whether it's possible to fix it without recompiling everything?

Thanks in advance,
Alex


Starting kernel ...

Uncompressing
Linux........................................................... done,
booting the kernel.
Linux version 2.6.20 (alex@linuxdev) (gcc version 4.1.2) #6 Thu Mar 1
12:34:00 EST 2007
CPU: ARM926EJ-S [41069265] revision 5 (ARMv5TEJ), cr=00053177
Machine: Atmel AT91SAM9260-EK
Memory policy: ECC disabled, Data cache writeback
On node 0 totalpages: 16384
 DMA zone: 128 pages used for memmap
 DMA zone: 0 pages reserved
 DMA zone: 16256 pages, LIFO batch:3
 Normal zone: 0 pages used for memmap
Clocks: CPU 198 MHz, master 99 MHz, main 18.432 MHz
CPU0: D VIVT write-back cache
CPU0: I cache: 8192 bytes, associativity 4, 32 byte lines, 64 sets
CPU0: D cache: 8192 bytes, associativity 4, 32 byte lines, 64 sets
Built 1 zonelists.  Total pages: 16256
Kernel command line: mem=64m console=ttyS0,115200 initrd=0x21100000,0xA00000
root=/dev/ram0 rw debug
AT91: 96 gpio irqs in 3 banks
PID hash table entries: 256 (order: 8, 1024 bytes)
Console: colour dummy device 80x30
Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
Memory: 64MB = 64MB total
Memory: 52760KB available (1592K code, 184K data, 88K init)
Calibrating delay loop... 99.12 BogoMIPS (lpj=495616)
Mount-cache hash table entries: 512
CPU: Testing write buffer coherency: ok
NET: Registered protocol family 16
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 2048 (order: 1, 8192 bytes)
TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
TCP: Hash tables configured (established 2048 bind 1024)
TCP reno registered
checking if image is initramfs...it isn't (bad gzip magic numbers); looks
like an initrd
Freeing initrd memory: 10240K
NetWinder Floating Point Emulator V0.97 (double precision)
io scheduler noop registered
io scheduler anticipatory registered (default)
atmel_usart.0: ttyS0 at MMIO 0xfefff200 (irq = 1) is a ATMEL_SERIAL
atmel_usart.1: ttyS1 at MMIO 0xfffb0000 (irq = 6) is a ATMEL_SERIAL
atmel_usart.2: ttyS2 at MMIO 0xfffb4000 (irq = 7) is a ATMEL_SERIAL
RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 blocksize
mice: PS/2 mouse device common for all mice
TCP cubic registered
NET: Registered protocol family 1
NET: Registered protocol family 17
RAMDISK: ext2 filesystem found at block 0
RAMDISK: Loading 5292KiB [1 disk] into ram disk... done.
VFS: Mounted root (ext2 filesystem).
Freeing init memory: 88K
/sbiKernel panic - not syncing: Attempted to kill init!
n/ init: can't load library 'libgcc_s.so.1'
-------------------------------------------------------------------
List admin: http://lists.arm.linux.org.uk/mailman/listinfo/linux-arm
FAQ:        http://www.arm.linux.org.uk/mailinglists/faq.php
Etiquette:  http://www.arm.linux.org.uk/mailinglists/etiquette.php

[Linux ARM]     [Linux ARM MSM]     [Linux ARM Kernel]     [Fedora ARM]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]

Add to Google Follow linuxarm on Twitter