Re: Should name based virtual hosts work when the ServerName is an IP address?

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]






--On 31 May 2012 08:34:42 +0100 Alex Bligh <alex@xxxxxxxxxxx> wrote:

To recap the problem is that accessing http://192.200.0.1/ returns the
default site (the first one), not the specific site (the third).

Suppose I change the line marked '*** THIS LINE ***" so it reads
 <VirtualHost *:80>  # <--- *** THIS LINE ***

Will that interfere in any way with the IP based virtual host which is
the fourth above? I have no other name based virtual hosts and even if
I did, I wouldn't mind this being the global default. And will it fix
the issue that http://192.200.0.1/ is not connecting to the third
virtual host block above?

This fails because <VirtualHost *:80> does not appear to set
a default when you also have a <VirtualHost 192.200.0.1:80>. The
latter always becomes the default.

--
Alex Bligh

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@xxxxxxxxxxxxxxxx
For additional commands, e-mail: users-help@xxxxxxxxxxxxxxxx



[Linux ACPI]     [Linux Kernel]     [Linux Laptop]     [Kernel Newbies]     [Share Photos]     [Security]     [Netfilter]     [Bugtraq]     [Squid]     [Photo]     [Yosemite Photos]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Samba]     [Video 4 Linux]     [Device Mapper]     [Linux Resources]


Add to Google Powered by Linux