Re: modernizing xdvi

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Mon, 20 Feb 2012 10:12:14 +0100 (CET)
Peter Breitenlohner <peb@xxxxxxxxxxxx> wrote:

> Why not use xdvik which is part of the TeX Live distribution (the
> current version is 22.16 with latest xdvi changes from May 2009,
> i..e, newer than 22.85 from Paul Vojta), or at least use that as a
> guide how to proceed?

Because I am not using TeX.  Because Paul Vojta still maintains a
distribution and clearly could use assistance keeping it up to date.
Because xdvik has more dependencies.  

I didn't post to discuss my motivation.  I posted because
"syntax error: unexpected end of file" is singularly unhelpful. I
posted because I followed, as best I could, the recommendations from
autoconf to modify the sources, and wound up with a nonworking script
despite no warnings or errors from the tools.  

FWIW, I actually began at the xdvik site (not vojta's).  It pointed me
to
http://sourceforge.net/projects/xdvi/files/latest/download?source=files,
which is supposed to be 22.85.  Same version, newer date.  Whatever.  

> > $ (autoconf --version; automake --version) |  grep ^auto
> > autoconf (GNU Autoconf) 2.61
> > automake (GNU automake) 1.10
> 
> IMHO it makes no sense to base new work on such ancient versions.

We have different opinions.  I am working with the tools I have, on two
platforms.  Chasing the latest version of autoconf is not my hobby.  

If you know the problem I'm reporting is fixed in a later version,
fine, I'll upgrade and move on.  If you, with your shiny new version,
can generate a working configure from my posted sources, I'll
gratefully adopt your version.  If not, I'd very much appreciate help
with the task at hand.  

But enough about me.  Let's talk about autoconf.  

--jkl

_______________________________________________
Autoconf mailing list
Autoconf@xxxxxxx
https://lists.gnu.org/mailman/listinfo/autoconf


[GCC Help]     [Kernel Discussion]     [RPM Discussion]     [Red Hat Development]     [Yosemite News]     [USB]     [Samba]

Add to Google Powered by Linux