[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Google
  Web www.spinics.net

Yum 3.4.3 and SLES11 SP1



Hi,

I am using yum 3.4.3 on our sles11 sp1 servers for updates.
Every time I have to install a new kernel, I get this error:

ERROR with transaction check vs depsolve:
kernel-default-base_x86_64 is needed by (installed) kernel-default-2.6.32.49-0.3.1.x86_64


Is this a yum problem? Or can I solve this?

Thanks!
Nicole

test01:~ # yum update
Loaded plugins: downloadonly, security
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package aaa_base.x86_64 0:11-6.38.1 will be updated
---> Package aaa_base.x86_64 0:11-6.46.42.1 will be an update
---> Package kernel-default.x86_64 0:2.6.32.54-0.3.1 will be installed
---> Package kernel-default-base.x86_64 0:2.6.32.49-0.3.1 will be updated
--> Processing Dependency: kernel-default-base_x86_64 = 2.6.32.49-0.3.1 for package: kernel-default-2.6.32.49-0.3.1.x86_64
---> Package kernel-default-base.x86_64 0:2.6.32.54-0.3.1 will be an update
---> Package kernel-default-devel.x86_64 0:2.6.32.49-0.3.1 will be updated
---> Package kernel-default-devel.x86_64 0:2.6.32.54-0.3.1 will be an update
---> Package kernel-source.x86_64 0:2.6.32.54-0.3.1 will be installed
--> Running transaction check
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================================================
 Package                                Arch                     Version                           Repository                           Size
=============================================================================================================================================
Installing:
 kernel-default                         x86_64                   2.6.32.54-0.3.1                   sles11sp1-updates                    16 M
 kernel-source                          x86_64                   2.6.32.54-0.3.1                   sles11sp1-updates                    69 M
Updating:
 aaa_base                               x86_64                   11-6.46.42.1                      sles11sp1-updates                   157 k
 kernel-default-base                    x86_64                   2.6.32.54-0.3.1                   sles11sp1-updates                   9.7 M
 kernel-default-devel                   x86_64                   2.6.32.54-0.3.1                   sles11sp1-updates                   2.5 M

Transaction Summary
=============================================================================================================================================
Install       2 Packages
Upgrade       3 Packages

Total download size: 98 M
Is this ok [y/N]: y
Downloading Packages:
(1/5): aaa_base-11-6.46.42.1.x86_64.rpm                                                                               | 157 kB     00:00
(2/5): kernel-default-2.6.32.54-0.3.1.x86_64.rpm                                                                      |  16 MB     00:00
(3/5): kernel-default-base-2.6.32.54-0.3.1.x86_64.rpm                                                                 | 9.7 MB     00:00
(4/5): kernel-default-devel-2.6.32.54-0.3.1.x86_64.rpm                                                                | 2.5 MB     00:00
(5/5): kernel-source-2.6.32.54-0.3.1.x86_64.rpm                                                                       |  69 MB     00:00
---------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                         85 MB/s |  98 MB     00:01
Running Transaction Check
ERROR with transaction check vs depsolve:
kernel-default-base_x86_64 is needed by (installed) kernel-default-2.6.32.49-0.3.1.x86_64
Please report this error in http://yum.baseurl.org/report
** Found 281 pre-existing rpmdb problem(s), 'yum check' output follows:
ConsoleKit-0.2.10-64.65.1.x86_64 is a duplicate with ConsoleKit-0.2.10-64.13.6.x86_64
ConsoleKit-32bit-0.2.10-64.65.1.x86_64 is a duplicate with ConsoleKit-32bit-0.2.10-64.13.6.x86_64
NetworkManager-glib-0.7.1_git20090811-3.9.9.5.x86_64 is a duplicate with NetworkManager-glib-0.7.0.r4359-15.22.49.x86_64
acpid-1.0.6-91.16.1.x86_64 is a duplicate with acpid-1.0.6-91.6.x86_64
alsa-1.0.18-16.24.1.x86_64 is a duplicate with alsa-1.0.18-16.9.29.x86_64
alsa-plugins-1.0.18-7.12.23.x86_64 is a duplicate with alsa-plugins-1.0.18-7.5.x86_64            


yum.conf:
[main]
cachedir=/var/cache/yum
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
exactarch=1
obsoletes=1
plugins=1
installonly_limit=3
_______________________________________________
Yum mailing list
Yum@xxxxxxxxxxxxxxxxx
http://lists.baseurl.org/mailman/listinfo/yum

[Home]     [Fedora Users]     [Fedora Legacy List]     [Fedora Maintainers]     [Fedora Desktop]     [Red Hat 9 Bible]     [Fedora Bible]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]

Powered by Linux

Google
  Web www.spinics.net