[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Google
  Web www.spinics.net

Re: i screwed up





On Thu, 13 May 2010, Richard Ray wrote:

I have several machine running CentOS
I upgraded all of them from 5.3 to 5.4
One machine has a yum problem after upgrading

# yum update
Loaded plugins: fastestmirror
Determining fastest mirrors
* addons: mirror.trouble-free.net
* base: mirror.team-cymru.org
* extras: mirror.team-cymru.org
* updates: mirror.raystedman.net
addons                                                   |  951 B 00:00
addons/primary                                           |  201 B 00:00
Traceback (most recent call last):
 File "/usr/bin/yum", line 29, in ?
   yummain.user_main(sys.argv[1:], exit_code=True)
 File "/usr/share/yum-cli/yummain.py", line 309, in user_main
   errcode = main(args)
 File "/usr/share/yum-cli/yummain.py", line 178, in main
   result, resultmsgs = base.doCommands()
 File "/usr/share/yum-cli/cli.py", line 345, in doCommands
   self._getTs(needTsRemove)
 File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 101, in
_getTs
   self._getTsInfo(remove_only)
File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 112, in _getTsInfo
   pkgSack = self.pkgSack
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 661, in <lambda>
   pkgSack = property(fget=lambda self: self._getSacks(),
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 501, in _getSacks
   self.repos.populateSack(which=repos)
File "/usr/lib/python2.4/site-packages/yum/repos.py", line 260, in populateSack
   sack.populate(repo, mdtype, callback, cacheonly)
File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 190, in populate
   dobj = repo_cache_function(xml, csum)
File "/usr/lib/python2.4/site-packages/sqlitecachec.py", line 42, in getPrimary
   self.repoid))
TypeError: Parsing primary.xml error: Start tag expected, '<' not found



I have tried 'yum clean all', 'yum --noplugins', 'rm -r /var/cache/yum/*',
deleting all yum packages and reinstalling, and nothing helps
If I copy /var/cache/yum/* from a working machine all is well
I have used md5sum to check the downloaded files and they match the files on a working machine
If I disable the addons repo the other repos load ok
Also rpmforge repo breaks yum
What else might I try


yum clean all didn't help it?

Are you perhaps running out of disk space somewhere?

B/c the above says you have a damaged primary.xml file - probably in the 'addons' repo.

is there anything 'funny' about this system?

-sv

_______________________________________________
Yum mailing list
Yum@xxxxxxxxxxxxxxxxx
http://lists.baseurl.org/mailman/listinfo/yum

[Home]     [Fedora Users]     [Fedora Legacy List]     [Fedora Maintainers]     [Fedora Desktop]     [Red Hat 9 Bible]     [Fedora Bible]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]

Powered by Linux

Google
  Web www.spinics.net