Re: Problems running virtual machines after an upgrade

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



On Sat, Feb 25, 2012 at 13:55:08 +0000, Bhasker C V wrote:
> Hi all,
> 
>  I upgraded qemu-kvm and libvirt to the new versions
>  qemu-kvm at : 1.0
>  libvirt at          : git version 0.9.10
> 
> I lost the original machines but the xml files were are all present (it
> is not showing up in virsh list --all)
> 
> But when I import an xml I get an error: Attached is some information
> which might be helpful
> Can someone help please ?
> 
> If this is a compatibility issue please can someone tell me which is the
> latest version of qemu-kvm and libvirt combination which will work ?
> I cannot use qemu plain since it does not yet support boot from scsi
> 
> thanks
> 
> -----------------------------------------------
> $ sudo virsh list --all
>  Id    Name                           State
> ----------------------------------------------------
> 
> $ lsmod | grep kvm
> kvm_intel             112920  0
> kvm                   280656  1 kvm_intel
>              
> $ /usr/local/sbin/libvirtd --version
> /usr/local/sbin/libvirtd (libvirt) 0.9.10
> 
> $ ./qemu-system-x86_64 --version
> QEMU emulator version 1.0-bcv (qemu-kvm-1.0), Copyright (c) 2003-2008
> Fabrice Bellard

Hmm, I suspect "1.0-bcv" version is not in the form we expect it to be. The
"-bcv" suffix causes this binary to be detected as qemu only, i.e., not kvm
capable... Which is wrong, btw, we should be detecting kvm capability by
checking -enable-kvm or -disable-kvm options since even plain qemu can use
kvm.

Jirka


[Index of Archives]     [Virt Tools]     [Lib OS Info]     [Fedora Users]     [Fedora Maintainers]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]

  Powered by Linux