Re: git repository access via HTTPS

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Mon, Jan 24, 2011 at 03:20:47PM +0200, Fyodor Kupchik wrote:
> still no luck with it :(
> I precede git command by proxychains one since git does not respect any kind
> of proxy settings (nor system wide or those I set via git config http.proxy)
> and it only works  in such way.
> ==============================================================================
> ProxyChains-3.1 (http://proxychains.sf.net)
> Initialized empty Git repository in
> /home/teo/prj/archipel/Archipel/Libvirt/.gnulib/.git/
> git.sv.gnu.org[0: 140.186.70.72]: errno=Connection refused
> fatal: unable to connect a socket (Connection refused)
> Clone of 'git://git.sv.gnu.org/gnulib.git' into submodule path '.gnulib'
> failed
> Failed to recurse into submodule path 'Libvirt'
> Unable to initialize submodules

This shows that the initial libvirt checkover over HTTP worked
fine.  What in fact failed was the attempt to checkout the
GNULIB submodule, which is still using git:// protocol. I don't
believe there is any way to change the protocol used for submodules
during initial checkout.


Regards,
Daniel


[Virt Tools]     [Lib OS Info]     [Fedora Users]     [Fedora Maintainers]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]

Powered by Linux

Google
  Web www.spinics.net