Re: Building an RPM

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hi,

I had tried that and found numerous packages that were needed as a pre-req, so I thought of trying the make rpm route.
Anyway, I went back to rpmbuild -ta and installed all the pre-req packages, RHEL has them in their repo so it made it easier than I though.
Except for "numad is needed by libvirt-0.9.11-1.el6.x86_64", and I can't find numad RHEL rpm, I am not sure where to get numad source code to compile?

Thanks



----- Original Message -----
From: Daniel Veillard <veillard@xxxxxxxxxx>
To: John Wayne <m01z04-libvirt@xxxxxxxxx>
Cc: "libvirt-users@xxxxxxxxxx" <libvirt-users@xxxxxxxxxx>
Sent: Thursday, April 19, 2012 12:24 AM
Subject: Re:  Building an RPM

On Wed, Apr 18, 2012 at 08:52:21PM -0700, John Wayne wrote:
> 
> 
> Hi,
> 
> I have downloaded libvirt-0.9.11 and compiled it on my RHEL 6.2 system.
> I am trying to build a binary RPM for distribution, I am not sure what the best way to go about doing this is.
> http://libvirt.org/FAQ.html suggests that I try 'make rpm', however that ends in the below error:
[...]
> Any clue on how to proceed? I am not sure why api.html is missing, since this is a clean untar of the 0.9.11 tar file, and './configure;make;make install' all worked without any issues.

  Try rpmbuild -ta libvirt-0.9.11.tar.gz

"make rpm" is more for people working out of a git checkout, ou may
end up with missing dependancies leading to a failure to "make dist".

rpmbuild may raise a number of missing dependencies that you may
have to supply locally first before actually making a build.

Daniel

-- 
Daniel Veillard      | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
daniel@xxxxxxxxxxxx  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/


_______________________________________________
libvirt-users mailing list
libvirt-users@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/libvirt-users



[Virt Tools]     [Lib OS Info]     [Fedora Users]     [Fedora Maintainers]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]

Powered by Linux

Google
  Web www.spinics.net