Google
  Web www.spinics.net

Re: Cannot %include in CentOS 5.5 kickstart

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


whitivery <co55-sy1t@xxxxxxxxxxxxxxx> wrote:

>I've previously used includes in CentOS 4.4 and they worked fine.
>
>But in CentOS 5.5, trying to specify a driver disk via an include
>does not work.
>
>If I instead specify it directly, it loads fine.
>
>When it fails (because it can't see the disk drive - needs the
>driver disk to see the hard disk), in Console 2 I can see that
>/tmp/drvdisk exists and has the line I wrote to it.  I see
>nothing that looks wrong in any log or kickstart file/fragment in
>/tmp.
>
>Any ideas? Here's my complete kickstart to show/test this:
>
>
># Minimal Kickstart test for CentOS 5.5 to show %include problem
>
>url --url=http://10.0.4.157/cblr/links/CentOS5.5-i386
>text
>lang en_US.UTF-8
>keyboard us
>
>timezone --utc America/New_York
>install
>bootloader --location=mbr
>clearpart --all --initlabel
>network --device eth0 --bootproto dhcp
>firewall --disabled
>selinux --disabled
>
>rootpw --iscrypted \$1\$x6z.qvwE\$7Zg9g1rCEgvOBoA7Oo/HF1
>zerombr
>authconfig  --useshadow  --enablemd5
>
>part /boot --fstype ext3 --size 100 --asprimary
>part / --fstype ext3 --size 1 --grow --asprimary
>part /var --fstype ext3 --size 10000
>part swap --recommended
>
>
># This does not work
>%include /tmp/drvdisk
>
># This works
>#driverdisk
>--source=nfs:10.0.4.157:/srv/cobbler/RHEL5.5_x86_402_409_410_DD.img
>
>
>%packages
>@base
>@core
>
>%pre --erroronfail
>
>echo "driverdisk
>--source=nfs:10.0.4.157:/srv/cobbler/RHEL5.5_x86_402_409_410_DD.img" >
>/tmp/drvdisk
>
>(end of kickstart file)

Follow-up: I can %include other kickstart bits just fine, such as the
partitioning commands.

I also tried using HTTP instead of NFS, with the same results.

I cannot think of anything else to try. Anaconda/kickstart seems to be
broken here.

I did a web search and didn't run across anything indicating that this is
a known bug.


_______________________________________________
Kickstart-list mailing list
Kickstart-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/kickstart-list


[Home]     [Fedora Users]     [Fedora Legacy]     [Fedora Maintainers]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]

Powered by Linux

Google
  Web www.spinics.net