Google
  Web www.spinics.net

Re: conflicting packages in kickstart

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hi Christian, I had a similar issue when using rpms I created. To get them
to install properly I needed to set the priority with yum priorities.

Here is an article that discusses how to do so for RPM Forge.  Look under
Point 2.  Where it says "2.1. Priorities" on the following link.


http://wiki.centos.org/AdditionalResources/Repositories/RPMForge

I would do this in the %post section
################
%post
yum install yum-plugin-priorities

cat <<EOF>> /etc/yum/pluginconf.d/priorities.conf
[main]
enabled=1
EOF

cat <<EOF>> /etc/my-custom-yum-repo.repo
 repo --name=csddev
--baseurl=http://amigo:82/home:/csd:/branches:/MeeGo:/1.0:/Core/ARM_Cross/
--save --debuginfo --source
repo --name=core  --baseurl=http://amigo:82/MeeGo:/1.0:/Core/ARM_Cross
 --save --debuginfo --source
priority=1
 EOF

## Then install the package
Yum erase    the-package-I-don't-want
Yum install my-special-package-with-a-duplicate-name
#############

I hope that helps.


Greg



On 9/23/10 11:24 AM, "Christian Daudt" <csd_b@xxxxxxxxx> wrote:

> [I tried #kickstart channel on IRC but it seems awfully quiet, so
> reposting to the list]
> hi,
>  I have a kickstart question (well Meego's image-creator, which uses
> kickstart): If I have 2 pkgs that provide the same thing, how can I
> get kickstart to be happy about using the one I picked? There is
> "grep.rpm"  already in one of the repos I'm using, and I added a
> busybox rpm with grep in it, which I want to use in my image instead
> of the grep already in the repo so I listed my busybox in the ks file,
> but it still tries to grab the grep rpm through other indirect
> dependencies and complains:
> Error: failed to create image : Unable to install: [('file /bin/grep
> conflicts between attempted installs of
> busybox-mxc-1.16.0-24.1.armv5tel and grep-2.5.3-6.1.armv5tel'
> I have the busybox rpm listed in my ks file but not the grep rpm (its
> being brought in indirectly). I even tried "-grep" in the rpm list to
> see if that would help but it didn't. Any pointers would be
> appreciated.
> 
> Here's are the relevant parts of the ks file I tried:
> ----------------------------------------------------------------
> ### repos start ###
> repo --name=csddev
> --baseurl=http://amigo:82/home:/csd:/branches:/MeeGo:/1.0:/Core/ARM_Cross/
> --save --debuginfo --source
> repo --name=core  --baseurl=http://amigo:82/MeeGo:/1.0:/Core/ARM_Cross
>  --save --debuginfo --source
> 
> 
> ### repos end ###
> 
> %packages --excludedocs
> 
> busybox-mxc <<<<< Comes from csddev repo above, and has a "provides:
> grep" defined in it, along with /bin/grep
> 
> -grep <<< tried both with this line and without it
> 
> openssh-server <<< this one is in repo "core" and pulls in "grep" rpm
> indirectly
> ---------------------------------------------------------------------------
> 
> thanks,
>    csd
> 
> _______________________________________________
> Kickstart-list mailing list
> Kickstart-list@xxxxxxxxxx
> https://www.redhat.com/mailman/listinfo/kickstart-list

_______________________________________________
Kickstart-list mailing list
Kickstart-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/kickstart-list


[Home]     [Fedora Users]     [Fedora Legacy]     [Fedora Maintainers]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]

Powered by Linux

Google
  Web www.spinics.net