Google
  Web www.spinics.net

Weird kickstart problem regarding not selecting the right cfg

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


We recently acquired four new machines (Sun X4270s). As usual as I've done with dozens of other machines I constructed RHEL5 kickstart .cfg files for them and made additions to the syslinux.cfg of the form:

label ct-phy-dom01
  kernel vmli5s64
  append initrd=int5s64.img ks=hd:sdb1:/configs/ct-phy-dom01.cfg console=ttyS0,9600
label ct-phy-dom02
  kernel vmli5s64
  append initrd=int5s64.img ks=hd:sdb1:/configs/ct-phy-dom02.cfg console=ttyS0,9600
label ct-phy-dom03
  kernel vmli5s64
  append initrd=int5s64.img ks=hd:sdb1:/configs/ct-phy-dom03.cfg console=ttyS0,9600
label ct-phy-dom04
  kernel vmli5s64
  append initrd=int5s64.img ks=hd:sdb1:/configs/ct-phy-dom04.cfg console=ttyS0,9600

# vmli5s64 = vmlinuz for RHEL5, server, 64bit
# int5s64.img = initrd.img for RHEL5, server, 64bit
# (note that the name of the initrd file must conform to 8.3 rules, just # like in DOS or it doesn't work!)

I placed the machine-specific .cfg files and the syslinux.cfg on a USB stick as we do for certain installs and powered the first machine (ct-phy-dom01) on. After typing "ct-phy-dom01" at the boot: line the machine installed via HTTP perfectly. However after that all the other machines failed to install. After watching ct-phy-dom02-4 repeatedly stop at the point at which they should load stage2.img from the HTTP server I theorised it was something to do with the network. Cue over an hour of network testing, changing cables, checking VLANs and adding ksdevice=<MAC address of chosen NIC in the server> to the syslinux.cfg. Nothing worked. At no point could I ping the IP (in the ks.cfg) of the box I was installing.

Eventually, even though I was booting via serial I plugged in a monitor and paged through the other virtual consoles and noticed that at install the machines were all selecting the ct-phy-dom01.cfg file despite what the syslinux.cfg specified. Obviously this meant they were trying to raise the IP of ct-phy-dom01 which had already been built and was up and running.

No matter what I tried I could not get any of the other machines (ct-phy-dom02-04) to use their own cfg files until I started commenting out the lines of servers I wasn't building in syslinux.cfg. Want to build ct-phy-dom02? Comment out ct-phy-dom01's lines. ct-phy-dom03? Comment out ct-phy-dom01 _and_ ct-phy-dom02. Etc.

Now, can anyone explain why?

Ben
--
Unix Support, MISD, University of Cambridge, England
Plugger of wire, typer of keyboard, imparter of Clue
        Life Is Short.          It's All Good.

_______________________________________________
Kickstart-list mailing list
Kickstart-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/kickstart-list


[Home]     [Fedora Users]     [Fedora Legacy]     [Fedora Maintainers]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]

Powered by Linux

Google
  Web www.spinics.net