Re: Unfinished transactions remaining:

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

On Tue, 22 May 2012 01:05:04 +0200, TM (Timothy) wrote:

> 
> A couple of days ago I started to yum-remove a package
> (I don't recall which)
> and I was told that a vast array of packages
> would also be removed.
> I ^C-ed to stop the process,
> as I wasn't sure whether I would be asked for my permission
> before the packages were removed.
> 
> Now when I run "yum update" I am told
> "There are unfinished transactions remaining.
> You might consider running yum-complete-transaction first to finish them."
> 
> If I run this program, I am again told that the same vast array of packages
> (including some if not all kernels) will be removed.
> Again I ^C to stop the program,
> as I am not sure my permission will be asked
> before the removal begins.
> 
> If I ignore the warning and continue yum-update
> I get the error
> -------------------------------
> Error: Package: glibc-2.12-1.47.el6_2.12.x86_64 (updates)
>            Requires: glibc-common = 2.12-1.47.el6_2.12
>            Installed: glibc-common-2.12-1.47.el6_2.9.x86_64 (@updates)
>                glibc-common = 2.12-1.47.el6_2.9
>            Available: glibc-common-2.12-1.47.el6.x86_64 (base)
>                glibc-common = 2.12-1.47.el6
>            Available: glibc-common-2.12-1.47.el6_2.5.x86_64 (updates)
>                glibc-common = 2.12-1.47.el6_2.5
>            Available: glibc-common-2.12-1.47.el6_2.12.x86_64 (updates)
>                glibc-common = 2.12-1.47.el6_2.12
>  You could try using --skip-broken to work around the problem
> ** Found 4 pre-existing rpmdb problem(s), 'yum check' output follows:
> bash-4.1.2-9.el6_2.x86_64 is a duplicate with bash-4.1.2-8.el6.centos.x86_64
> glibc-common-2.12-1.47.el6_2.12.x86_64 is a duplicate with glibc-
> common-2.12-1.47.el6_2.9.x86_64
> glibc-common-2.12-1.47.el6_2.12.x86_64 has missing requires of config(glibc-
> common) = ('0', '2.12', '1.47.el6_2.12')
> glibc-common-2.12-1.47.el6_2.12.x86_64 has missing requires of glibc = ('0', 
> '2.12', '1.47.el6_2.12')
> -------------------------------
> 
> I've tried all the cleanup measures I know, "sudo yum clean all",
> "sudo package-cleanup --dupes", "sudo package-cleanup --problems",
> "sudo yum update glibc glibc-common", but none of them do the trick.
> 
> Any advice or suggestions gratefully received.
> 
> Ps: I should have confessed at the outset that this is on a machine
> running CentOS-6.2.
> But the problem seems a generic yum issue.

Not really. You've messed up your installation a bit, and taking a look
at the full output of

  rpm -qa glibc\* bash\*

would be helpful. Plain RPM does still exist, so certainly it's possible
to remove duplicate packages with "rpm" and appropriate options.

-- 
Fedora release 17 (Beefy Miracle) - Linux 3.3.6-3.fc17.x86_64
loadavg: 0.47 0.33 0.47
-- 
users mailing list
users@xxxxxxxxxxxxxxxxxxxxxxx
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org



Photo 4 Less

[Older Fedora Users]     [Fedora Announce]     [Fedora Package Announce]     [EPEL Announce]     [Fedora News]     [Fedora Cloud]     [Fedora Advisory Board]     [Fedora Education]     [Fedora Security]     [Fedora Scitech]     [Fedora Robotics]     [Fedora Maintainers]     [Fedora Infrastructure]     [Fedora Websites]     [Anaconda Devel]     [Fedora Devel Java]     [Fedora Legacy]     [Fedora Desktop]     [Fedora Fonts]     [ATA RAID]     [Fedora Marketing]     [Fedora Management Tools]     [Fedora Mentors]     [SSH]     [Find Someone Special]     [Fedora Package Review]     [Fedora R Devel]     [Fedora PHP Devel]     [Kickstart]     [Fedora Music]     [Fedora Packaging]     [Centos]     [Fedora SELinux]     [Fedora Legal]     [Fedora Kernel]     [Fedora QA]     [Fedora Triage]     [Fedora OCaml]     [Coolkey]     [Virtualization Tools]     [ET Management Tools]     [Yum Users]     [Tux]     [Yosemite News]     [Yosemite Photos]     [Linux Apps]     [Maemo Users]     [Gnome Users]     [KDE Users]     [Fedora Tools]     [Fedora Art]     [Fedora Docs]     [Maemo Users]     [Asterisk PBX]     [Fedora Sparc]     [Fedora Universal Network Connector]     [Libvirt Users]     [Fedora ARM]

Add to Google Powered by Linux