Re: F16, XFCE/LXDE and hibernate button

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Proof my brain has not been working right lately --

On Wed, Apr 11, 2012 at 11:42 AM, Joel Rees <joel.rees@xxxxxxxxx> wrote:
> On Wed, Apr 11, 2012 at 9:50 AM, Rick Stevens
> <rstevens@xxxxxxxxxxxxxxxxxxx> wrote:
>> On 04/10/2012 03:55 PM, Joel Rees wrote:
>>>
>>> Anybody using XFCE or LXDE who are missing their hibernate button in
>>> the logout dialog after the recent kernel upgrade?
>>
>>
>> Which new kernel? I'm running 3.3.1-3.fc16.x86_64 and I see it.
>
> 3.3.1-3.fc16.i686
>
> If you're getting yours, it probably is not the kernel, so, ...
>
>>> Or should I suspect that moving the /home partition to a new partition
>>> yesterday is to blame?
>>
>> Possibly.
>>
>>> (Need to look up what I have to do with SELinux after a move like
>>> this. I remember there's something that needs to be done, don't
>>> remember exactly what.)
>>
>> "restorecon -R -v /home" I believe.
>
> Yeah. Restore context. That's one thing I need to do.
>
> Reset a bunch of context. but there's still no hibernate. Durn.
>

Today, I finally did what I should've done four days ago:

STW on "hibernate setting xfce"

Google gave me some nice threads on xfconf-query:

http://forum.xfce.org/viewtopic.php?id=4781
http://ubuntuforums.org/showthread.php?t=1830829

No man entry for xfconf-query, but --help gives enough clues for what
I might have needed in another case, but not here. setting the
hibernate setting to true with

xfconf-query -c xfce4-session -np '/shutdown/ShowHibernate' -t 'bool' -s 'true'

didn't help.

But this topic give me the clue I really needed:

http://forums.linuxmint.com/viewtopic.php?f=197&t=97684

Really simple. on4aa pointed out that I need a functional swap for
hibernate to work. Since I had moved both /home and swap, I thought
maybe I should check, and, sure enough, swapon -s listed no active
swap. Checking /etc/fstab (Significantly cleaner on this netbook with
a fresh f16 than on my aging tower with an install that I've been
upgrading since F10 or before.) showed the entry for swap, so I tried

swapon -a

and got a message about the UUID not matching. Yep. Never fixed it
after the move. I guess the dd on the /home partition restored the
UUID, since it matches what is in fstab. Anyway,

ls -l /dev/disk/by-uuid

showed me the new UUID, and I checked the swap partition again with
gparted because my memory just ain't what it used to be, and edited
the fstab swap entry with the new UUID and now swapon -a turns the
swap on and, yay! there is my hibernate button.

Thanks for the suggestions, Rick and Bruno.

--
Joel Rees
-- 
users mailing list
users@xxxxxxxxxxxxxxxxxxxxxxx
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org



Photo 4 Less

[Older Fedora Users]     [Fedora Announce]     [Fedora Package Announce]     [EPEL Announce]     [Fedora News]     [Fedora Cloud]     [Fedora Advisory Board]     [Fedora Education]     [Fedora Security]     [Fedora Scitech]     [Fedora Robotics]     [Fedora Maintainers]     [Fedora Infrastructure]     [Fedora Websites]     [Anaconda Devel]     [Fedora Devel Java]     [Fedora Legacy]     [Fedora Desktop]     [Fedora Fonts]     [ATA RAID]     [Fedora Marketing]     [Fedora Management Tools]     [Fedora Mentors]     [SSH]     [Find Someone Special]     [Fedora Package Review]     [Fedora R Devel]     [Fedora PHP Devel]     [Kickstart]     [Fedora Music]     [Fedora Packaging]     [Centos]     [Fedora SELinux]     [Fedora Legal]     [Fedora Kernel]     [Fedora QA]     [Fedora Triage]     [Fedora OCaml]     [Coolkey]     [Virtualization Tools]     [ET Management Tools]     [Yum Users]     [Tux]     [Yosemite News]     [Yosemite Photos]     [Linux Apps]     [Maemo Users]     [Gnome Users]     [KDE Users]     [Fedora Tools]     [Fedora Art]     [Fedora Docs]     [Maemo Users]     [Asterisk PBX]     [Fedora Sparc]     [Fedora Universal Network Connector]     [Libvirt Users]     [Fedora ARM]

Add to Google Powered by Linux