Google
  Web www.spinics.net

[Fedora-r-devel-list] R2spec kibitzing.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Sorry, those messages were supposed to have come out periodically over
the last week or two.

I've got the next version ready, tested as I had alluded to in my previous. 

http://nersp.osg.ufl.edu/~asr/media/R2spec-2.6.1-asr.src.rpm

So, here's what I did to get more or less useful results out of it:

After installing, I made a temp directory, /var/tmp/Rstuff.

There, I ran (as root): 

# clear; R2spec  -n "Allen S. Rout" -e "asr@xxxxxxx"  -c   --force  --suggests  --verbose  --package  ggplot2


This downloaded the CRAN-like lists of packages, downloaded source
tarballs, and built (and copied) the specfiles and source.  

It also generated a few dot files, including the broad and narrow
dependency graphs for the requested package.

It also generates a shell file: 'rpmbuild.sh'.  This is intended to
make all the RPMs you need for the broad graph. 

I haven't decided what the sane options are in terms of 'pwd'
throughout all this process.  At the moment, the next step is:

# cd /usr/src/redhat/SPECS
# sh /var/tmp/Rstuff/rpmbuild.sh

This will build and install all of the RPMs in the broad graph. ... If
the individual builds work.

This script uses a tempdir extensively, again I'm not sure what the
Right Way is to do this, I haven't thought about it too much yet.
It's statically defined at the beginning of the script to be

/var/tmp/Rstuff

that's obviously inappropriate for release, but will do for the
moment.

The script drops a build log and an install log for every package
addressed. 



Right now, for me to get the sysdeps to build and install all (most)
of ggplot2's broad depgraph, I must:

yum install openmpi openmpi-devel openmpi-libs unixODBC-devel pvm tcl tcl-devel perl-DateManip  perl-Date-Calc perl-version

and then install from EPEL:

environment-modules-3.2.6-4.el5.x86_64.rpm
mpich2-1.1.1-1.el5.x86_64.rpm
perl-IO-stringy-2.110-5.el5.noarch.rpm
perl-Jcode-2.06-6.el5.noarch.rpm
perl-OLE-Storage_Lite-0.14-9.el5.noarch.rpm
perl-Parse-RecDescent-1.96-1.el5.noarch.rpm
perl-Spreadsheet-WriteExcel-2.18-1.el5.noarch.rpm
perl-Unicode-Map-0.112-12.el5.x86_64.rpm

and then install from the graphviz people: 

graphviz-2.24.0-1.el5.x86_64.rpm
graphviz-devel-2.24.0-1.el5.x86_64.rpm


With these things done, I still fail to build (and haven't
investigated much yet):


tcltk2:  Fails to install: need tclsh8.3, not 8.4 ? 

multcomp: requires Survival >= 2.35.7 ? ...

flexmix: dep on multcomp

R-RandomFields, R-MCMCpack: uncaught debug files in the build tree.

MPI, sprng




As threatened, my next step will be a similar shell script to R CMD
CHECK all the packages, and populate yet another family of logfiles.
Once that is complete, I will re-announce and go back to try to figure
out why individual packages fail.



- Allen S. Rout

_______________________________________________
Fedora-r-devel-list mailing list
Fedora-r-devel-list@xxxxxxxxxx
http://www.redhat.com/mailman/listinfo/fedora-r-devel-list

[Home]     [Fedora Users]     [Fedora Legacy List]     [Fedora Maintainers]     [Fedora Desktop]     [Red Hat 9 Bible]     [Fedora Bible]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]

Powered by Linux

Google
  Web www.spinics.net