Google
  Web www.spinics.net

PHP with libmysql OR mysqlnd

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hi,

PHP team will set mysqlnd as the default mysql driver for 5.4.
Mysqlnd seems to be promoted as the "best" and "stable" mysql driver.

I'd like to offer the user the choice beetwen libmysql and mysqlnd as
soon as possible (and of course, keep this choice as long as possible)

It is now possible to build mysqlnd as a shared extension, so it is
possible to provide both drivers.
	https://bugs.php.net/bug.php?id=55609

I have a working spec,

Changes :

* build-cgi

	Build mysqlnd, mysql, mysqli and pdo_mysql (and others)

* build-apache

	Build mysql, mysqli and pdo_mysql (with libmysql)

* extension rename

	in order to have extensions for both drivers in
	the install tree, I need to rename extension
	in a way which preserve load order

	mysqlnd
	mysqlnd_mysql (after mysqlnd)
	mysqlnd_mysqli
	pdo_mysqlnd (after mysqlnd and pdo)

* package php-mysql

	=> Conflicts with php-mysqlnd

* package php-mysqlnd

	=> provides both php-mysql and php-mysqli

A small question :
what package yum will pull when a webapp requires php-mysql ?


Any comment ?
Ok, to push this to rawhide ? F-16 ?

Remi

P.S.
https://github.com/remicollet/remirepo/commit/cf67bae6d0964743c144bb2ac4a3a3b1e199d370
_______________________________________________
php-devel mailing list
php-devel@xxxxxxxxxxxxxxxxxxxxxxx
https://admin.fedoraproject.org/mailman/listinfo/php-devel


[Home]     [Fedora Users]     [Fedora Legacy List]     [Fedora Maintainers]     [Fedora Desktop]     [Red Hat 9 Bible]     [Fedora Bible]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]

Powered by Linux

Google
  Web www.spinics.net