Google
  Web www.spinics.net

Re: Fedora Legacy Update : kdelibs dependency problems

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


A E Lawrence wrote:

Trying to update (yum) the kdelibs and kdelibs-devel rpms fails on a AMD64 FC3 legacy system because all the other kde packages appear to require kdebase-3.3.1-4.3.FC3.

I can't see anyone else reporting this problem in the archives of this list, so I am mystified. I suspect that I can force the upgrade without breaking anything by a manual "rpm -Fhv -- nodeps ...", but I shouldn't need to do this, should I?

-F doesn't do a forced install, it is the 'freshen' option (only updates packages if they're already installed). It looks like the packaging is a bit funky. A file that is part of kdebase-3.3.1 is now found in kdelibs-3.4.2 and a file that was in kdeartwork is now found in kdelibs. It looks to me the old layout was correct and the new kdelibs incorporates files it shouldn't. Note: I don't run 64 bit Fedora and I don't use KDE either.

Nils.

--

fedora-legacy-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/fedora-legacy-list

[Fedora Development]     [Fedora Announce]     [Fedora Legacy Announce]     [Fedora Config]     [PAM]     [Fedora General Discussion]     [Big List of Linux Books]     [Gimp]     [Free Internet Dating]     [Yosemite Questions]

Powered by Linux