Google
  Web www.spinics.net

Re: [389-devel] 1.2.6-1 crash

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Could you do "thread apply all bt", once you see this Segmentation fault message?

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fe4a23e9710 (LWP 9557)]
0x00007fe4d1fc601c in attrlist_find_or_create_locking_optional () from /usr/lib64/dirsrv/libslapd.so.0
(gdb) thread apply all bt


On 09/29/2010 01:29 PM, Gary Morris wrote:
sure.. i'll do that and rerun them.. 

On Wed, Sep 29, 2010 at 4:25 PM, Noriko Hosoi <nhosoi@xxxxxxxxxx> wrote:
 On 09/29/2010 12:49 PM, Rich Megginson wrote:
Gary Morris wrote:
ah.. sorry.. ok.. just retried with 1.2.6.1-1.. /

[root@dalp-ct02 logs]# rpm -qa | grep 389
389-dsgw-1.1.5-1.fc13.x86_64
389-admin-console-1.1.5-1.fc13.noarch
389-admin-1.1.11-1.fc13.x86_64
389-ds-base-1.2.6.1-1.fc13.x86_64
389-ds-console-1.2.3-1.fc13.noarch
389-admin-console-doc-1.1.5-1.fc13.noarch
389-console-1.1.4-1.fc13.noarch
389-adminutil-1.1.9-1.fc13.x86_64
389-ds-console-doc-1.2.3-1.fc13.noarch
389-ds-1.2.1-1.fc13.noarch

I got some gdb output. I tried 5 times and got 3 distinct functions..
the output in order is below:
So 1.2.6.1 is still crashing :-(
in gdb, do this:
thread apply all bt
and post the output here
Before running the crash test, could you install 389-ds-base-debuginfo?

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f81897fb710 (LWP 5328)]
0x00007f81adc5be28 in attrlist_delete () from
/usr/lib64/dirsrv/libslapd.so.0
(gdb)

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f4012dea710 (LWP 6263)]
0x00007f40432ca01c in attrlist_find_or_create_locking_optional () from
/usr/lib64/dirsrv/libslapd.so.0
(gdb)

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fe3b03f9710 (LWP 6778)]
0x00007fe3d6f3aea1 in valuearray_add_valuearray_fast () from
/usr/lib64/dirsrv/libslapd.so.0
(gdb)

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f5c31bf5710 (LWP 7275)]
0x00007f5c59549ea1 in valuearray_add_valuearray_fast () from
/usr/lib64/dirsrv/libslapd.so.0
(gdb)

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7ff0485e6710 (LWP 7556)]
0x00007ff079a4e01c in attrlist_find_or_create_locking_optional () from
/usr/lib64/dirsrv/libslapd.so.0

I'm happy to assist in any way I can to resolve.

much thanks!
-gary

On Wed, Sep 29, 2010 at 10:14 AM, Rich Megginson<rmeggins@xxxxxxxxxx
<mailto:rmeggins@xxxxxxxxxx>>  wrote:

    Gary Morris wrote:
    >
    >  ok.. it pulled 389-ds-base-1.2.6-2.fc13.x86_64.. is that ok or do i
    >  need to be on 1.2.6-1?  On 1.2.6-2 I'm having the same problem.  As
    >  soon as I start an application that is ldap intensive, the directory
    >  server crashes real quick.  No errors of any sort reported.
    No, it should be 1.2.6.1-1, not 1.2.6-1, not 1.2.6-2.
    Looks like 1.2.6.1-1 is not yet in the mirrors, so if you want to
    try it
    in the meantime, you'll have to install it directly from koji:
    http://koji.fedoraproject.org/koji/buildinfo?buildID=196612
    >
    >  On Tue, Sep 28, 2010 at 11:16 PM, Rich Megginson
    <rmeggins@xxxxxxxxxx<mailto:rmeggins@xxxxxxxxxx>
    >  <mailto:rmeggins@xxxxxxxxxx<mailto:rmeggins@xxxxxxxxxx>>>  wrote:
    >
    >      Gary Morris wrote:
    >      >  Hi guys.. i'm running 389-ds-base-1.2.6-1.fc13.x86_64 and
    the server
    >      >  is crashing repeatedly, mostly under load.  There are
    about 390,000
    >      >  ldap entries in the database. I tried installing on a
    couple of
    >      >  different servers (Fedora 13) with the same problem.  The
    >      problem does
    >      >  not seem to be happening on 1.2.6-0.1.  I would be happy
    to send you
    >      >  more details on what is causing the crash if I could
    figure out
    >      how to
    >      >  do that.  When I put any load on the server, it crashes,
    and often
    >      >  crashes before it can even fully start.  It does not seem
    to crash
    >      >  when I turn on the heavy debugging, but then again,
    performance is
    >      >  very slow on full debug.  If anyone has some suggestions
    on what
    >      I can
    >      >  do to give more information, i'd be happy to.
    >      There were a couple of crashing bugs that have been fixed in
    >      1.2.6.1-1 -
    >      now available in the Testing repos.  Please try to install
    >      389-ds-base-1.2.6.1-1 from the updates-testing repo and see
    if that
    >      fixes your problem.
    >      >
    >      >  -gary
    >      >
    >
    ------------------------------------------------------------------------
    >      >
    >      >  --
    >      >  389-devel mailing list
    >      >  389-devel@xxxxxxxxxxxxxxxxxxxxxxx
    <mailto:389-devel@xxxxxxxxxxxxxxxxxxxxxxx>
    >      <mailto:389-devel@xxxxxxxxxxxxxxxxxxxxxxx
    <mailto:389-devel@xxxxxxxxxxxxxxxxxxxxxxx>>
    >      >  https://admin.fedoraproject.org/mailman/listinfo/389-devel
    >
    >      --
    >      389-devel mailing list
    >      389-devel@xxxxxxxxxxxxxxxxxxxxxxx
    <mailto:389-devel@xxxxxxxxxxxxxxxxxxxxxxx>
    >      <mailto:389-devel@xxxxxxxxxxxxxxxxxxxxxxx
    <mailto:389-devel@xxxxxxxxxxxxxxxxxxxxxxx>>
    >      https://admin.fedoraproject.org/mailman/listinfo/389-devel
    >
    >
    >
    ------------------------------------------------------------------------
    >
    >  --
    >  389-devel mailing list
    >  389-devel@xxxxxxxxxxxxxxxxxxxxxxx
    <mailto:389-devel@xxxxxxxxxxxxxxxxxxxxxxx>
    >  https://admin.fedoraproject.org/mailman/listinfo/389-devel

    --
    389-devel mailing list
    389-devel@xxxxxxxxxxxxxxxxxxxxxxx
    <mailto:389-devel@xxxxxxxxxxxxxxxxxxxxxxx>
    https://admin.fedoraproject.org/mailman/listinfo/389-devel


------------------------------------------------------------------------

--
389-devel mailing list
389-devel@xxxxxxxxxxxxxxxxxxxxxxx
https://admin.fedoraproject.org/mailman/listinfo/389-devel
--
389-devel mailing list
389-devel@xxxxxxxxxxxxxxxxxxxxxxx
https://admin.fedoraproject.org/mailman/listinfo/389-devel



--
389-devel mailing list
389-devel@xxxxxxxxxxxxxxxxxxxxxxx
https://admin.fedoraproject.org/mailman/listinfo/389-devel

-- 389-devel mailing list 389-devel@xxxxxxxxxxxxxxxxxxxxxxx https://admin.fedoraproject.org/mailman/listinfo/389-devel

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature

--
389-devel mailing list
389-devel@xxxxxxxxxxxxxxxxxxxxxxx
https://admin.fedoraproject.org/mailman/listinfo/389-devel

[Fedora Directory Announce]     [Older Fedora Users Mail]     [Home]     [Fedora Advisory Board]     [Fedora Security]     [Fedora Maintainers]     [Fedora Devel Java]     [Fedora Legacy]     [Fedora Desktop]     [iPod Nano]     [ATA RAID]     [Fedora Bible]     [Fedora Marketing]     [Fedora Mentors]     [Fedora Package Review]     [Fedora Art]     [Fedora Music]     [Fedora Packaging]     [Centos]     [Fedora SELinux]     [Tux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Art]     [Fedora Docs]

Powered by Linux

Google
  Web www.spinics.net