[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building against java-1.5.0-gcj-devel instead of java-1.6.0-openjdk-devel



On 30 December 2010 18:05, Orion Poplawski <orion@xxxxxxxxxxxxx> wrote:
> On 12/30/2010 10:57 AM, Richard Fearn wrote:
>> Hi,
>>
>> I'm building jcip-annotations for x86_64 rawhide using mock on my F14
>> x86_64 laptop. The package BuildRequires java-devel>= 1.5.0 and
>> java-1.6.0-openjdk-devel is being installed to satisfy that
>> dependency.
>>
>> When requesting a scratch build, such as this one:
>>
>>    http://koji.fedoraproject.org/koji/taskinfo?taskID=2694190
>>
>> java-1.5.0-gcj-devel is installed instead. Anyone know why? I expected
>> the latest version to be used for the Koji build.
>
> I think it is because yum uses package name length in this case (for lack of
> any better information) to pick between java-1.5.0-gcj-devel and
> java-1.6.0-openjdk-devel.  They both satisfy java-devel >= 1.5.0 so in theory
> either should be fine.
>

Orion is right in that either should be fine because both satisfy that
requirement, but I too have found javadoc generation to be
particularly flakey with GCJ.

In order to work around this, I think it is ok to BuildRequire
java-devel >= 1:1.6.0 as long as you build with source=1.5 and
target=1.5.

-- 
Mat Booth
http://fedoraproject.org/get-fedora
--
java-devel mailing list
java-devel@xxxxxxxxxxxxxxxxxxxxxxx
https://admin.fedoraproject.org/mailman/listinfo/java-devel



[Index of Archives]     [Fedora Maintainers]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]     [Fedora Tools]

  Powered by Linux