[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Google
  Web www.spinics.net

JUnit4 being obsoleted by JUnit



Recent versions of JUnit4 have backward compatible layer that is able to
emulate JUnit versions 3.x.x. We currently have 4.8.2 in rawhide thanks to
Alexander Kurtakov. 

I have done some testing of this backward compatibility and I was able
to successfully replace junit with recent junit4 and build packages:
 * jakarta-commons-logging
 * jakarta-commons-io
 * jakarta-commons-dbcp
 * eclipse (unmodified spec, but replaced junit.jar symlink in
   /usr/share/java with junit4.jar)

This means we can begin phasing out separate junit4 package and
basically overwrite junit package with it. This will be done probably
in the next few days. New version of junit will of course offer backward
compatible symlinks, so no modifications to your packages should be
necessary. Problems might occur anyway, so take this as a heads-up.

junit package in devel is currently orpahned and I plan to take it and
do these changes, unless anyone has conflicting ideas. Other ideas are
welcome too of course.

-- 
Stanislav Ochotnicky <sochotnicky@xxxxxxxxxx>
Associate Software Engineer - Base Operating Systems Brno

PGP: 71A1677C
Red Hat Inc.                               http://cz.redhat.com

Attachment: signature.asc
Description: PGP signature

--
java-devel mailing list
java-devel@xxxxxxxxxxxxxxxxxxxxxxx
https://admin.fedoraproject.org/mailman/listinfo/java-devel

[Home]     [Fedora Legacy List]     [Fedora Maintainers]     [Fedora Desktop]     [Red Hat 9 Bible]     [Fedora Bible]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]

Powered by Linux

Google
  Web www.spinics.net