Google
  Web www.spinics.net

Re: tftp config for virt-manager or virt-install

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On 06/16/2009 07:34 AM, Gianluca Cecchi wrote:
> Hello,
> already posted yesterday to fedora-virt but htis seems more correct
> one. Excuse for duplicate.
> I'm on a x86_64 F11 host.
> I created with success CentOS 5.3 and Windows 2003 vms from iso images.
> If I try to create a VM from virt-manager with pxe, I see from ps that
> inside the qemu command (tried with both qemu and qemu/kvm)
> there is the
> -boot n
> option, but there aren't any
> -tftp dir
> and/or
> -bootp file
> options....
> 
> Is there any default for qemu and/or virt-manager?
> Also with virt-install I was not able to have it pick up these options....
> (tried --extra-args but it doesn't seem the correct way)
> ps output is:
> 
> root      3577     1 99 14:52 ?        02:37:30 /usr/bin/qemu-kvm -S
> -M pc -m 768 -smp 1 -name slackware64 -uuid
> 4e3c9c56-695a-b5a5-ff87-ab0807b19d63 -monitor pty -pidfile
> /var/run/libvirt/qemu//slackware64.pid -no-reboot -boot n -drive
> file=/dev/vg_qemu01/slack64,if=ide,index=0 -net
> nic,macaddr=54:52:00:56:19:31,vlan=0 -net
> tap,fd=19,script=,vlan=0,ifname=vnet3 -serial pty -parallel none -usb
> -vnc 127.0.0.1:3 -soundhw es1370
> 
> The installation remains in attemp to get the tftp file without
> success (it give "no filename" and continues to loop)
> It seems that the guest gets one of the available ip provided by
> dhcpd, also it founds dhcpd and tftp server: both are set to
> 192.168.122.1 (the server itself with its virbr0 default bridge interface).
> No particular configuration done by me for network.
> I see /etc/libvirt/qemu/networks/default.xml with some parameters but
> I don't know if and how I can put here also tftp settings....
> 
> I also see /var/lib/libvirt/images and tried to create here a pxeboot
> dir with pxelinux.0, vmlinuz and initrd.img files but no way...
> Is this implemented yet? Any way to pass the tftp parfameters to the
> forked qemu command?
> Thanks for any pointer to docs that can help.
> 

Libvirt does not support the tftp or bootp parameters, so virt-manager has no
choice in the matter. From the sound of the qemu docs, these options are only
useful for usermode networking, which it doesn't look like you are using. You
should be able to use a regular PXE server on your network.

Thanks,
Cole

_______________________________________________
et-mgmt-tools mailing list
et-mgmt-tools@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/et-mgmt-tools

[Home]     [Fedora Users]     [Fedora Legacy List]     [Fedora Maintainers]     [Fedora Desktop]     [Red Hat 9 Bible]     [Fedora Bible]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]

Powered by Linux

Google
  Web www.spinics.net