Google
  Web www.spinics.net

Re: Fedora with XFS /boot

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


2012/6/18 Eric Sandeen <sandeen@xxxxxxxxxx>:
> On 6/17/12 5:10 PM, Marcos Felipe Rasia de Mello wrote:
>> Hi,
>>
>> Anaconda does not allow put the /boot directory on a XFS filesystem. I
>> did a test using the great FSArchiver, which enables you to save an
>> image from any supported filesystem (including all data properties and
>> attributes) and restoring it into a *different* one (kepping the
>> original UUID).
>>
>> First, I installed Fedora 17 on a single EXT4 partition (no
>> RAID/LVM/swap), then inside SystemRescueCd saved the filesystem:
>>
>> fsarchiver -v -z 2 -j 2 savefs /mnt/windows/fedora.fsa /dev/sda1    #
>> /mnt/windows is a CIFS share
>>
>> To be sure nothing was left from GRUB2:
>>
>> dd if=/dev/zero of=/dev/sda count=600k
>> sync
>> parted -s /dev/sda -- mklabel msdos
>> parted -s /dev/sda -- mkpart primary xfs 0% 100%
>> parted -s /dev/sda -- set 1 boot on
>> partprobe /dev/sda
>>
>> Now, put the filesystem back on XFS:
>>
>> fsarchiver -v -j 2 restfs /mnt/windows/fedora.fsa id=0,dest=/dev/sda1,mkfs=xfs
>>
>> Reinstall GRUB2:
>>
>> mkdir /mnt/fedora
>> mount /dev/sda1 /mnt/fedora
>> mount --bind /dev /mnt/fedora/dev
>> mount --bind /proc /mnt/fedora/proc
>> mount --bind /sys /mnt/fedora/sys
>> chroot /mnt/fedora /bin/sh
>> grub2-install /dev/sda
>> exit
>> nano /mnt/fedora/etc/fstab    # change filesystem type from ext4 to xfs
>> umount /mnt/fedora/* /mnt/fedora
>>
>> Reboot.
>>
>> All worked fine! XFS /boot...
>>
>> Digging into xfs mailing list I discovered the problem GRUB has with
>> XFS is that it can not be installed *on the partition*, because unlike
>> EXT filesystems XFS uses its first sector. Which is a shame for people
>> who only install GRUB on the MBR like me.
>>
>> Would be possible for Anaconda allow XFS at /boot while check for GRUB
>> on the partition case?
>
> You are right that grub must live in the MBR and not on the XFS partition since
> XFS uses sector 0.
>
> Aside from that, old grub code sometimes broke when it tried to read & write
> directly from/to the block device while it was mounted.  That this even worked
> on ext3 was a miracle.  ;)  I presume grub2 is better, at some point I should
> go audit what it's doing I suppose, but your test looks like a good datapoint,
> thanks.
>

Thank you. I look forward to see it working.

Marcos

_______________________________________________
Anaconda-devel-list mailing list
Anaconda-devel-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/anaconda-devel-list



[Home]     [Fedora Users]     [Fedora Legacy List]     [Fedora Maintainers]     [Fedora Desktop]     [Red Hat 9 Bible]     [Fedora Bible]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]

Powered by Linux

Google
  Web www.spinics.net