Re: Can't get Soundblaster X-Fi Titanium to work. What else should I try?

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



Hi doug@xxxxxxxxxxxx!

 On 2012.03.02 at 15:13:27 -0700, doug@xxxxxxxxxxxx wrote next:

> I'm trying to set up a RedHat 5, update 4, 64 bit workstation for audio
> playback.  I found the X-Fi Titanium at a local store and checked the ALSA
> soundcard matrix which said that it is partially supported.  I don't really
> need anything other than playback, so that seemed alright to me.
> 
> I downloaded ALSA 1.0.25 and followed the INSTALL document, but when I get to
> step 8 and give the command "modprobe snd-ctxfi" I get the error: "snd_ctxfi:
> Unknown symbol try_to_del_timer_sync".

Redhat isn't exactly the best distro regarding multimedia support, and
this is the cause of your problem. This card most likely isn't
supported.. by downloading fresh alsa you might make it work but there
are no promises - as you saw, it didn't help you.

RHEL 5 update 4 is very old, and I doubt there is easy way of making it
work, at least while sticking with that version. You might replace
kernel, but there is no point in using Redhat then, as you will lose
support by doing this. You might try to update to 5.8, but I'm really
not sure if it's going to solve this problem.

If you have support contract, try reinstalling system to RHEL 6.2.
Redhat server licenses allow you to use any version - I haven't checked
if it's the same with workstation licenses, but most probably it is.

If you don't have active Red Hat support contract, then I might suggest
you some free alternative like Scientific Linux 6.2 or CentOS 6.2 - if
you prefer RHEL-compatible distro for one reason or another. They have
more or less fresh X-Fi driver. If RHEL compatibility doesn't matter to
you, you can pick any popular modern Linux distro, be that Fedora,
Ubuntu, OpenSUSE, Mint or tons of others. As long as it's not too old,
X-Fi will work just fine.

> 
> I also tried downloading and building XFiDrv_Linux_Public_US_1.00.tar.gz from
> Creative, but when I run make, I get the error: "cthw20k2.c:1315: error:
> implicit declaration of function 'mdelay'".

That driver is even less supported, so don't follow this path at all :)

-- 

Vladimir

------------------------------------------------------------------------------
Virtualization & Cloud Management Using Capacity Planning
Cloud computing makes use of virtualization - but cloud computing 
also focuses on allowing computing to be delivered as a service.
http://www.accelacomm.com/jaw/sfnl/114/51521223/
_______________________________________________
Alsa-user mailing list
Alsa-user@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/alsa-user


[ALSA Devel]     [Linux Audio Users]     [Fedora Users]     [Fedora Desktop]     [Free Dating Site]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]

Powered by Linux