Alsa not using requested device

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



Hi,
I'm stuck with this, and not getting anywhere.
I'm using an application called wsjt which uses portaudio, now I guess no-one will read beyond this
point.
BUT alsa is the back end

Audio     Input    Output     Device Name
Device  Channels  Channels
------------------------------------------------------------------
   0       12        10       M Audio Delta 66: ICE1712 multi (hw:0,0)
   1        2         0       Conexant CX8801: CX88 Digital (hw:1,0)
   2        2         0       HDA ATI SB: ALC892 Analog (hw:2,0)
   3        2         2       HDA ATI SB: ALC892 Digital (hw:2,1)
   4        2         0       HDA ATI SB: ALC892 Analog (hw:2,2)
   5        0         8       HDA NVidia: HDMI 0 (hw:3,3)
   6        0         8       HDA NVidia: HDMI 1 (hw:3,7)
   7        0        128       front
   8        0        128       surround40
   9        0        128       surround41
  10        0        128       surround50
  11        0        128       surround51
  12        0        128       iec958
  13       128        128       spdif
  14       32        32       pulse
  15        0        10       dmix
  16       32        32       default
  17       16        16       /dev/dsp
  18       16         0       /dev/dsp1
  19       16         0       /dev/dsp2

User requested devices:   Input =  0   Output =  0
Default devices:          Input = 16   Output = 16
Will open devices:        Input = 16   Output = 16

This app uses 11025 as a sampling rate so the only device it can use is dev 0 hw,0,0

PortAudio version number = 1899
PortAudio version text = 'PortAudio V19-devel (built Dec  2 2011 09:24:12)'
Number of devices = 20
--------------------------------------- device #0
Name                        = M Audio Delta 66: ICE1712 multi (hw:0,0)
Host API                    = ALSA
Max inputs = 12, Max outputs = 10
Default low input latency   =    0.012
Default low output latency  =    0.012
Default high input latency  =    0.046
Default high output latency =    0.046
Default sample rate         = 44100.00
Supported standard sample rates
 for half-duplex 16 bit 12 channel input = 
         8000.00,  9600.00, 11025.00, 12000.00,
        16000.00, 22050.00, 24000.00, 32000.00,
        44100.00, 48000.00, 88200.00, 96000.00
Supported standard sample rates
 for half-duplex 16 bit 10 channel output = 
         8000.00,  9600.00, 11025.00, 12000.00,
        16000.00, 22050.00, 24000.00, 32000.00,
        44100.00, 48000.00, 88200.00, 96000.00
Supported standard sample rates
 for full-duplex 16 bit 12 channel input, 10 channel output = 
         8000.00,  9600.00, 11025.00, 12000.00,
        16000.00, 22050.00, 24000.00, 32000.00,
        44100.00, 48000.00, 88200.00, 96000.00

pa_devs reports the device as having 11025 as a sampling rate.

richard@g8jvm:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: M66 [M Audio Delta 66], device 0: ICE1712 multi [ICE1712 multi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: SB [HDA ATI SB], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: SB [HDA ATI SB], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 3: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 3: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

alsa-base =1.0.23
alsa-utils = 1.0.24.2-4


I can set in the wsjt config to use either M66,dev 0 or hw:0,0 but no matter what I set it to with the
exception of pulse, it reverts to default and uses card 2 [HDA ATI SB].

Could I please have some help with this, the changes recently have been to alsa, portaudio hasn't
changed for a year.
TIA
-- 
Best wishes / 73
Richard Bown

e-mail: richard@xxxxxxxxx   or   richard.bown@xxxxxxxxxxxxxxxx

nil carborundum a illegitemis
##################################################################################
Ham Call G8JVM . OS Debian Wheezy/Sid amd64 on a Dual core AMD Athlon 5200, 4 GB RAM
Maidenhead QRA: IO82SP38, LAT. 52 39.720' N LONG. 2 28.171 W ( degs mins )
QRV HF + VHF Microwave 23 cms:140W,13 cms:100W,6 cms:10W & 3 cms:5W
################################################################################## 

------------------------------------------------------------------------------
All the data continuously generated in your IT infrastructure 
contains a definitive record of customers, application performance, 
security threats, fraudulent activity, and more. Splunk takes this 
data and makes sense of it. IT sense. And common sense.
http://p.sf.net/sfu/splunk-novd2d
_______________________________________________
Alsa-user mailing list
Alsa-user@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/alsa-user


[ALSA Devel]     [Linux Audio Users]     [Fedora Users]     [Fedora Desktop]     [Free Dating Site]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]

Powered by Linux