dmix problem on PXA270 + AC97 codec

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



Hello,

I have an embedded system that contains:

- PXA270 ARM cpu
- UCB1400 AC97 codec
- ALSA (libasound) 1.0.24
- 3.0 kernel

When I run aplay <wavefile>, it works fine.

When I run  -D plug:dmix <wavefile>, it appears to be playing (don't
see any error messages, runs for expected amount of time), but I hear
silence.

With last year's software (2.6.27 kernel, alsa 1.0.23), dmix works fine.

I tried replacing alsa 1.0.24 with 1.0.23, and it still does not work,
so perhaps the issue is with the kernel?

Does anyone have suggestions on how to debug this issue?  I have not
found any other easy way to mix sound from several sources, so it
would be really nice to get this working.

Thanks,
Cliff

-- 
=================
http://bec-systems.com

------------------------------------------------------------------------------
The demand for IT networking professionals continues to grow, and the
demand for specialized networking skills is growing even more rapidly.
Take a complimentary Learning@Cisco Self-Assessment and learn 
about Cisco certifications, training, and career opportunities. 
http://p.sf.net/sfu/cisco-dev2dev
_______________________________________________
Alsa-user mailing list
Alsa-user@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/alsa-user


[ALSA Devel]     [Linux Audio Users]     [Fedora Users]     [Fedora Desktop]     [Free Dating Site]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]

Powered by Linux